PDK applications are aborted when 5.24 ActivePerl is used

Posted by seongkuk@qti.qualcomm.com on 2016-10-17 17:39
Forums: PDK Support | OS: Windows 7

Using ActivePerl 5.24.0 Build 2400 (64-bit)
& PDK 9.5.1 (64bit) on Win 7 64-bit.

when I try to launch perlapp, it will say "C:\Program Files\ActiveState Perl Deve Kit 9.5.1\bin\perlapp.exe is not recognized as a PDK tool" as attached picture

Any help is much appreciated.

AttachmentSize
error_perlapp.png8.13 KB

i-shenl
ActiveState Staff
Tue, 2016-10-18 07:50

ActivePerl 5.24 is not compatible with PDK 9.5.1. You need to use ActivePerl 5.22 instead.
PDK 9.6 will be compatible with 5.24 but it is not yet available.

You will need to do the following:

1) Uninstall both PDK and 5.24.

2) Download ActivePerl 5.22 from this link:
http://downloads.activestate.com/ActivePerl/releases/5.22.1.2201/

3) Install PDK

grahams
ActiveState Staff
Wed, 2017-02-22 11:11

wayneras | Thu, 2017-07-06 20:07

When when will support stop for PDK 9.5.1? If it effecively already has, as of when?