PDK 9.5 PerlApp Cannot browse to set new location for the perl executable

Posted by barryhall_zeninternet on 2017-12-28 20:24

OS X 10.13.1

Just upgraded to PDK 9.5 and to ActiveStatePerl 5.24.3. In the PerlApp GUI the location shown in the Perl field is that for the earlier version of ActiveStatePerl, v5.16.

When I browse to the usr/local/ActivePerl-5.24/bin directory all of the files are greyed out ad I cannot select the perl file - or any other file for that matter.

PerlApp is still set to access ActivePerl-5.16, and if I change the name of the directory from ActivePerl-5.16 to **ActivePerl-5.16 then PerlApp will not open at all.

grahams
ActiveState Staff
Fri, 2017-12-29 09:10

PDK is no longer being sold. PAR packer might work for you, and other companies are still making roughly similar tools, but current Community ActivePerls are not licensed for use with either of these routes.

See this FAQ:
https://community.activestate.com/faq/finalversionpairingsPDK

If you must use ActivePerl, you're going to have to uninstall 5.24.3, and the Perl Dev Kit, and then re-install the PDK after you have a compatible ActivePerl installed. That will require a Business Edition license now.

You might find you need to roll back your OS X upgrade too. None of the compatible ActivePerls are known to work on the latest OS X. Depending on their age, they are for OS X 10.7 through 10.10. They are unsupported on 10.13.