mod_perl-2.0.ppd installation failed

Posted by nedg on 2018-05-25 01:38
Forums: PPM | OS: Windows Server 2012

When I try to install a mod_perl-2.0.ppd with command line:

ppm install http://theoryx5.uwinnipeg.ca/ppms/mod_perl-2.0.ppd

I am getting this error:

ppm install failed: 500 Can't connect to theoryx5.unwinnipeg.ca:80 (nodename nor servername provided, or not know)

Active perl version is 5.24.3. URL is unreachable in browser, so this repository no longer exists.

Can anyone help me fix this or to find appropriate repository ?

grahams
ActiveState Staff
Fri, 2018-05-25 13:13

Looks like you're using some old docs.

Theoryx5 was one of the four PPM repositories maintained by Randy Kobes at the University of Winnipeg. Theoryx5 held binaries for use with Perl 5.8. They would be incompatible with any other version of Perl.

Randy Kobes was a big supporter of mod_perl, and making mod_perl accessible was one of his motivations for maintaining his repo projects. Unfortunately, Randy passed away in 2010. After his death the repos were sporadically maintained, but a few years back the University shut them all down permanently.

There were no other repositories that provided mod_perl in binary form, in large part because mod_perl is more properly an Apache project than Perl. As far as I know, the only way to get mod_perl now is to build it yourself from the source code, and using the instructions provided by the mod_perl team.