All / Any

PPM for Perl 5.8 is Frozen

PPM services for Perl 5.8 are outdated, and should not be used.

The final update for all 5.8 PPM3 based systems was September of 2009. All 5.8 PPM3 servers have been decommissioned since 2010.

Date of last 5.8 update for PPM4 based systems:
Windows 32-bit - March 2010
Windows 64-bit - Never Supported
Linux 32-bit - March 2010
Linux 64-bit - March 2010
OS X - March 2010
Solaris 32-bit - March 2010
Solaris 64-bit - Never Supported
Solaris Intelx86 - Never Supported
AIX 32-bit - Never Supported
HPUX RISC 32-bit - Never Supported

Release Notes for 5.24.2.2403

Due to a problem on the main docs site, the 2402 version of the Release Notes is still the latest available.

You can see the latest version in the documentation inside the ActivePerl 2403 version. For those who can't install it, here is the list of changes between 2402 and 2403:
-----------------------------------------------------------------------

ActivePerl 5.24 Change Log

For the latest information on ActivePerl, please see:

http://www.ActiveState.com/ActivePerl/

Build 2403, August 2017

Build 2403 is based on Perl 5.24.2 plus additional selected changes.

Final Version pairings for ActivePerl with Perl Dev Kit

Question: 

I want to upgrade ActivePerl and my Perl Dev Kit. What's available?

Answer: 

------------Update April 2019---------------------
Advisory:
If you still have a working instance of the Perl Dev Kit, DO NOT alter it.
- Do not attempt to move it to a newer system.
- Do not attempt to update to a newer version of Perl
- Do not attempt to update to a newer version of the Perl Dev Kit
- Do not attempt to update any modules from PPM
- Do not install system updates
All of these actions carry varying levels of risk, ranging from very high to moderate, of rendering your Perl Dev Kit instance abruptly and irreparably broken.

PDK has been discontinued for three years. All users need to be winding down any use of the Perl Dev Kit as rapidly as possible.

-------End of Update----------

You may have already seen the announcement... Last year, ActiveState announced that the direction for the company's future will be OpenSource Languages.

http://www.activestate.com/blog/2016/11/activestate-open-source-language...
http://www.activestate.com/blog/2016/12/open-source-languages-company-up...

Proprietary tooling for certain languages is not part of the OpenSource Languages Company future. Sales of both of the Dev Kit tools sets were discontinued at the time of those announcements. New licenses for PDK and TDK will not be available as separate products.
http://www.activestate.com/perl-dev-kit

Engineering and Development time and resources were immediately priorized for updating the existing language distributions. In 2017, work is starting on the new languages. Work was stopped on PDK, and that means that there will not be a PDK 9.6.

Existing copies of PDK 9.5.1 cannot use the latest releases of ActivePerl. The 2203 and 2204 builds are not compatible, and all 5.24 versions remain incompatible with the final release of PDK 9.5.1.

----Update September 2017------

Since the End of Sales for PDK, there have been enough newer versions of Perl released by the Perl Community that none of ActivePerl versions compatible with the Perl Dev Kit are still Supported by the Community. With no supported, free, versions of Community Edition ActivePerl available, Users of the Perl Dev Kit will need at least a Business Edition license to access a compatible version of ActivePerl.

-------End of Update----------

2202 is the last compatible ActivePerl, except on OS X.

For OS X, the 9.5.1 release of PDK was created on OS X 10.5. Every PDK must have a 100% binary compatible ActivePerl. ActivePerls switched from building on OS X 10.5 to building on OS X 10.9 at 5.22.2.2202 and are now 64-bit only. These two factors are responsible for the unresolvable symbols error message. Since there will not be a 9.6 that is also built on OS X 10.9, the 2201 release is the last ActivePerl that is compatible.

Upgrading from Perl < 5.14 using PPM vs upgrading from Perl >= 5.14 using PPM

The documentation for ActivePerl 5.8 through 5.12 still describes a process that only worked when upgrading from 5.6.x, or 5.8.8.817 and older, to a newer Perl.

The CPAN/PPM module "PPM::Profile" is only compatible with Perls using the old PPM version 3.x. It will not create a usable file from a Perl with PPM version 4.x.

Users upgrading from a 5.8 through 5.12 Perl should use a script instead of the old module. Thanks to user "berniec" for posting an example script in the Installation forum:

https://community.activestate.com/node/10420#comment-27084

Known Issues in recent releases

This posting will track known issues with the current set of Community Edition releases.

- perdoc errors On Windows
Versions affected
5.24.1.2402 and 5.22.3.2204 (Versions using perldoc v3.27)
Components affected: perldoc
Symptoms: perdoc errors with "invalid argument: -R"
Workaround: perldoc -T (document) | more
Bug Status: Core Perl bug
Fix Availability: Fix expected in the next ActiveState releases for 5.24 and 5.22.

- MicroSoft Compilers are incompatible -
Versions affected:
All 5.18, 5.20, 5.22, 5.24

HeartBleed vulnerability and ActivePerl

Question: 

Is my Community/Business/Enterprise Edition version of ActivePerl vulnerable to HeartBleed?

Answer: 

ActivePerl Community/Business Editions which, as shipped, are affected:
- 5.14.4.1405 - upgrade to 5.14.4.1406 (Business Edition only) or 5.16.3.1604 to fix
- 5.16.3.1603 - upgrade to 5.16.3.1604 to fix
- 5.18.1.1800 - upgrade to 5.18.2.1802 to fix
- 5.18.2.1801 - upgrade to 5.18.2.1802 to fix

Modules supplied through PPM are unaffected.
Modules compiled locally must be reviewed locally for vulnerability.

Enterprise Editions can be distinguished from Community/Business Editions by the presence of an additional fifth number before the six digit build number/version control number.
ActivePerl Enterprise Editions which, as shipped, are affected:
- 5.8.9.829.9 through 829.12
- 5.10.1.1009.9 through 1009.12
- 5.12.5.1206.2 through 1206.5
- 5.14.3.1404.2 through 1405.3
- 5.16.2.1602.2 through 1603.3

New Enterprise releases have been issued and can be located under the 2014Q1.1 folder.

HeartBleed vulnerability and ActivePython

Question: 

Is my Community/Business/Enterprise Edition version of ActivePython vulnerable to HeartBleed?

Answer: 

No Enterprise versions of ActivePython are vulnerable.

No Community/Business Edition versions of ActivePython 2.x and no Community/Business Edition versions of ActivePython 3.0, 3.1, and 3.2 are vulnerable to HeartBleed.

Only Community/Business Edition ActivePython 3.3.2.0 and 3.3.4.1 are vulnerable.
An updated 3.3 release will be needed to address the vulnerability.

Having a problem? Check here first:

Frequently encountered problems may have an FAQ available.

http://community.activestate.com/faq-list?tid=55

Having a problem? Check here first:

Frequently encountered problems may have an FAQ available.

http://community.activestate.com/faq-list?tid=54

Having a problem? Check here first:

Frequently encountered problems may have an FAQ available.

http://community.activestate.com/faq-list?tid=50