Linux

The old PPM FAQ

The old-style manuals had a useful FAQ for PPM. It can still be accessed, and still applies with newer version numbers.

http://docs.activestate.com/activeperl/5.20/

Support for armv71/Raspbian?

All;
I was wondering if there is a supported version of Active Perl for the armv71/Raspbian architecture and OS? Are there any plans in the future?
Thanks;
FSD

Perl installation error

Hi, I tried to install ActivePerl on Linux ( 64 bit ). I got the following error.

perl/bin/perl: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by perl/bin/perl)

Please let me know the solution.

Thanks,
Chaitu

ActiveState Support Policy for ActivePerl Community Editions

Question: 

What is ActiveState's Support Policy for Community Editions?

Answer: 

The two most recent stable releases are available for free download. This corresponds to the Perl Community's own version support policy.

Whenever the underlying Perl version becomes unsupported by the Perl community itself, support for the corresponding ActivePerl versions will be limited to Business Edition and Enterprise Edition customers.

You can continue to use older ActivePerl releases indefinitely under the terms of the Community Edition license, but won't be able to download the installers from ActiveState.

The PPM repositories for unsupported ActivePerl releases will remain freely accessible for at least 6 months after support ends, but will no longer be updated with new builds from CPAN.

Komodo won't start on linux due to missing symbol

Question: 

Komodo won't start on linux, complains about gdk_window_get_visual symbol

Answer: 

On certain older (mostly RedHat based) linux distros Komodo will fail to start with the following error:

undefined symbol: gdk_window_get_visual

To fix this error you simply need to install the "gdk-pixbuf2" package. The name varies per distro, but searching for "pixbuf" should get you the right package name.

Corrupted Files when running the ActivePerl Linux installer

Question: 

When I run the installer, it reports that several files are corrupted. I see this error:
This installer package does not have the expected content. Please try to download a fresh copy of ActivePerl from ActiveState's website at activestate.com. If you still have problems please contact us at SupportEmail.

How do I fix this?

Answer: 

---Updated 10/18:
This FAQ applies to ALL ActivePerl Linux tarball installers.
A link to a current version has been specified solely for convenience
---
There are two possible causes.

1) If you used the command line "tar" to extract the archive, and tar reported this:
"tar: Removing leading / from member names"
the version of tar you have installed is removing leading slashes by default as a security measure. This will break the ActivePerl installer. Delete the extracted folder and run tar with different options.
"tar -zxPf (filename for the ActivePerl installer tarball with extensions.)"

2) If you allowed your browser to extract the tarball, it will have use the Linux Archive Manager. Trash the ActivePerl folder you extracted. Download a fresh copy, and do not open the Download with the Linux Archive Manager.
Go to a Terminal Window, and extract the file on the command line, using GNUtar instead:
http://docs.activestate.com/activeperl/5.26/get/linux/
You may still hit the leading slash issue if your tar has that default behaviour.

MCE 1.504 was released, but the build error for Perl 5.14 under Linux (x86, 64-bit) isn't due to MCE

Greetings,

I took a look at http://code.activestate.com/ppm/MCE/ and see that the 1.504 build failed for Linux (64-bit). But the reason doesn't appear to be coming from MCE. It looks like it was fine for 1.503 though.

Regards,

Mario

NET::SSH2

I need the Net :: SSH2 package, but not in the list of PPM, I am using ActiveState and PDF for linux, someone has managed to install?

When the Ruby debugger bails out with an obscure error message (Linux 64-bit)

Question: 

When I try to use the Ruby debugger, on a 64-bit Linux machine, stops after giving this error message:

Error: cannot load such file --
/home/lorned/Komodo-IDE-8/lib/support/dbgp/rubylib/1.9/../lib/trace_nums19

What should I do?

Answer: 

So trace_nums.so is a Ruby C-extension that is used by the debugger, and
normally can be completely ignored. It was a bit puzzling why Ruby wasn't
loading this file, as it was clearly present and on Ruby's library load
path.

I got the customer who reported this problem to fire up irb, cd'ed to
the directory containing trace_nums.so, and run `require 'trace_nums19'`.
He reported this error message:

irb(main):002:0> require './trace_nums19'
LoadError: libruby.so.1.9: cannot open shared object file: No such file or
directory -
/home/abc/Komodo-IDE-8/lib/support/dbgp/rubylib/1.9.3/x86_64/trace_nums19.so
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from (irb):2
        from /usr/bin/irb:12:in `<main>'

The customer had /usr/lib/libruby-1.9.1.so installed, but not libruby-so.1.9
I see that rvm installs libruby.so.1.9.1 in each directory, and then
creates symbolic links libruby.so and libruby.so.1.9 pointing to it, so the
libruby-so.M-N form looks correct. But this naming is inconsistent -- Python
puts the version numbers before the ".so" extension, while Perl and Ruby
typically put them after.

Anyway, the simple fix was to run

cd /usr/lib
sudo ln -s libruby-1.9.1.so libruby.so.1.9

Can't seem to get tk compiled-in when using tclapp

I have TDK5.2 with ActiveTcl-8.5 installed.
My system is
Linux opteron4 2.6.18-164.15.1.el5 #1 SMP Mon Mar 1 10:56:08 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

I am trying to wrap my tk application with tclapp.
My command is

% tclapp -prefix ~/ActiveTcl-8.5/bin/base-tk8.5-thread-linux-ix86 -out myapp dbgMain.tcl *.tcl

I am afraid myapp is not getting the tk prefix compiled in.
myapp fails when it encounters any tk function call and quits
To confirm this, I added the following on top of my code

if {[info commands winfo] == ""} {
puts "tk was not initialized properly"